$re = '/\d+(?![^,])|(?<=,)\d+/m';
$str = '12,334,455
24,G4,G5';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);