// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"showPollResponses\((.*())").unwrap();
let string = "</thead>
<tr>
<td class=\"oddpoll\" style=\"width:20%\"><b><a href=\"#\" onclick=\"showPollResponses(123456, 99, '1A2B3C4D5E6F7G8H9I0J1K2L3M4N5O6P', 123456, 123456, 99);return false;\">The stuf (i</a></b>
<br>
</td><td class=\"oddpoll\" style=\"width:35%\">The content was pretty nice and would participate again </td><td class=\"oddpoll\" style=\"width:45%\"><b>123 Total</b>
<br>
</td>
</tr>
<tr>
<td class=\"oddpoll\"> </td>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}