re = /"[^"\\]*(?:\\.[^"\\]*)*"|'[^'\\]*(?:\\.[^'\\]*)*'|([^"']+)/m
str = 'searchword outside "inside searchword" searchword \'searchword\''
# Print the match result
str.scan(re) do |match|
puts match.to_s
end