$re = '/[^\p{L}\p{P}]+/mu';
$str = 'abcd 123 kjd ยค%/(" .?:!';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);