re = /^(?!.*New in Release 2.7.7).*$/m
str = 'I know that I can negate group of chars as in [^bar] but I need a regular expression where negation applies to the specific word - so in my example how do I negate an actual bar, and not "any chars in bar"? What\'s New in Release 2.7.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end