package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:\w+\s\binterface\b\s\w+)`)
var str = `public interface ISomething`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}