re = /([a-z0-9.]*)|(\/{1,})/m
str = 'demo.codesamplez.com/html5/////////////////////////audio/////wsfsdf////ghghgh/jhjhj//////ghghgh'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end