re = /SELECT (.+?) FROM INSERTED/im
str = 'SELECT \'Hello, world!\' FROM INSERTED i'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end