use strict;
my $str = '<!-- ceci est une version anonymisée de https://cadiwww.epfl.ch/listes?groupe=epfl-dojo -->
<html>
<head>
<title>Liste <a href="mailto:noreply@epfl.ch">noreply@epfl.ch</a> (15 personnes) :</title>
<link rel="stylesheet" href="https://www.epfl.ch/styles/dynastyle.php" media="screen">
</head>
<body bgcolor="white">
<h3>Liste <a href="mailto:noreply@epfl.ch">noreply@epfl.ch</a> (15 personnes) :</h3>
<ul>
<a href="/listes?sciper=162141">Prentice Anna</a><br>
<a href="/listes?sciper=191824">Reuben Katy</a><br>
<a href="/listes?sciper=117417">Jodi Edwige</a><br>
<a href="/listes?sciper=183535">Roger Gaétane</a><br>
<a href="/listes?sciper=177895">James Laurent</a><br>
<a href="/listes?sciper=127103">Gilmore Jean-Daniel</a><br>
<a href="/listes?sciper=169419">Thorpe Nicolas</a><br>
<a href="/listes?sciper=184984">Parris Billie-Jo</a><br>
<a href="/listes?sciper=183672">Horner Barbara</a><br>
<a href="/listes?sciper=152148">Daniels Moïse</a><br>
<a href="/listes?sciper=157966">Lott Noah</a><br>
<a href="/listes?sciper=174223">Ester Polly</a><br>
<a href="/listes?sciper=162990">Bull Terry</a><br>
<a href="/listes?sciper=103088">White E. Pearl</a><br>
<a href="/listes?sciper=156713">Peace Warren</a><br>
</ul>
</body>
</html>
';
my $regex = qr/\?sciper=([0-9]{1,})[^0-9]>(.*?)<\/a>/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}