$re = '/(?=.*preis)(?=.*Strom).*$/im';
$str = 'asalsöfj Strom Preis löasfj asdf
asalsöfj Preis löasfj Strom asdf';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);