import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(S\\w.*\\d[:])|(([0-9.]+|(-[0-9.]+)))|([A-Z]{2}\\b)";
final String string = "ACTIONS: \n"
+ " [ { LONGITUDES: \n"
+ " { SHUTTLE_LON_A6: [ 748, [ 'CI', 76.5, 980.5 ] ],\n"
+ " SHUTTLE_LON_A5: \n"
+ " [ 271,\n"
+ " [ 'CL', 0, 76.5 ],\n"
+ " [ 'CI', 76.5, 980.5 ],\n"
+ " [ 'CL', 980.5, 1057 ] ],\n"
+ " SHUTTLE_LON_A4: [ 129 ],\n"
+ " SHUTTLE_LON_A3: [ 107 ],\n"
+ " SHUTTLE_LON_A2: [ -35 ],\n"
+ " SHUTTLE_LON_A1: [ -57 ] },\n"
+ " LATITUDES: { SHUTTLE_LAT_1: [ [ 1057 ] ] } },\n"
+ " { LONGITUDES: \n"
+ " { SHUTTLE_LON_A6: [ 978, [ 'CL', 76.5, 980.5 ] ],\n"
+ " SHUTTLE_LON_A5: \n"
+ " [ 727,\n"
+ " [ 'CL', 0, 76.5 ],\n"
+ " [ 'CI', 76.5, 980.5 ],\n"
+ " [ 'CL', 980.5, 1057 ] ],\n"
+ " SHUTTLE_LON_A4: [ 250, [ 'CI', 76.5, 980.5 ] ],\n"
+ " SHUTTLE_LON_A3: [ 20, [ 'CL', 76.5, 980.5 ] ],\n"
+ " SHUTTLE_LON_A2: [ -122 ],\n"
+ " SHUTTLE_LON_A1: [ -144 ] },\n"
+ " LATITUDES: \n"
+ " { SHUTTLE_LAT_1: \n"
+ " [ [ 20.5, [ 'CI', 0, 1100 ] ],\n"
+ " [ 34.5, [ 'CI', 0, 1100 ] ],\n"
+ " [ 58.5, [ 'CI', 0, 1100 ] ],\n"
+ " [ 76.5,\n"
+ " [ 'CL', 0, 271 ],\n"
+ " [ 'CI', 271, 727 ],\n"
+ " [ 'CL', 727, 1100 ] ],\n"
+ " [ 980.5,\n"
+ " [ 'CL', 0, 271 ],\n"
+ " [ 'CI', 271, 727 ],\n"
+ " [ 'CL', 727, 1100 ] ],\n"
+ " [ 998.5, [ 'CI', 0, 1100 ] ],\n"
+ " [ 1022.5, [ 'CI', 0, 1100 ] ],\n"
+ " [ 1036.5, [ 'CI', 0, 1100 ] ],\n"
+ " [ 1057, [ 'CL', 0, 1100 ] ],\n"
+ " [ 1057 ] ] } } ] } ]";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}