#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\(([^,]*),([^,]*),([^,]*),([^,]*),([^,]*)\)"
Local $sString = "foo,(4568,'самый лучший','солнечная погода',NULL,3),bar" & @CRLF & _
"fizz,(7835,'sup','789 y',NULL,9),buzz" & @CRLF & _
"abracadabra" & @CRLF & _
"to many items,(7835,'sup','789 y',NULL,9,1111111111111111),buzz" & @CRLF & _
"less than five items,(7835,'sup','789 y',NULL),buzz" & @CRLF & _
"hello,(56498123,'atdaadf','kr',NULL,5),world" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")