re = /(?<=\()*(\(([^()]*|(?-))*\))/m
str = '(())
vhjhg(&-:__(-5_:;+)&&;+5)
(()())((()))'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end