#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ms)\W+注册单位:\W+注册编号/执业印章号:(\W|\d)+注册专业:\W+有效期:\d+年\d+月\d+日"
Local $sString = "一级注册建造师" & @CRLF & _
"注册单位:" & @CRLF & _
"云南移民产业投融资有限公司" & @CRLF & _
"注册编号/执业印章号:" & @CRLF & _
"云1532018201900531" & @CRLF & _
"注册专业:" & @CRLF & _
"建筑工程" & @CRLF & _
"有效期:" & @CRLF & _
"2026年08月23日"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")