import Foundation
let pattern = #"\bB(\d+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"B54 B65 Bob S45"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"Bond \1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)