re = /^1?[-. ]?(?:\((\d{3})\)|(\d{3}))[-. ]?(\d{3})[-. ]?(\d{4})$/m
str = '1 555) 555 5555
1 (555 555 5555
1 (555) 555 5555'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end