$re = '/(?=pr)|pr+\K/m';
$str = 'zprzzzprrrrrzpzr';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);