$re = '/([^,]+), (\1(, |$))+/m';
$str = 'abc, abc, 123';
$subst = "\1\3";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;