# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\[quote name='(.+?)'(.*?)\](.*?)\[/quote\]"
test_str = ("[quote name='Hale' timestamp='1366473099' post='272041']<br />\n"
"Sì, ma come mai non chiudono siti come TNT ecc se è illegale, e poi, io c'avessi i soldi mi comprerei anche i dvd, ma ...<br />\n"
"[/quote]<br />\n"
"Mi sono chiesto spesso anch'io perché non chiudano siti che violano palesemente il diritto d'autore, ma non ho mai trovato la risposta. Certo che, potevi chiederglielo tu visto che hai avuto la fortuna di incontrarli. <img src='http://localhost/forum/public/style_emoticons/<#EMO_DIR#>/003.gif' class='bbc_emoticon' alt=';-)' /> Probabilmente hanno le loro priorità. Penso che prima della pirateria, si concentrino sulla lotta contro la pedopornografia.<br />\n"
"Poi l'obiezione che spesso viene fatta a chi scarica illegalmente e si giustifica dicendo di non avere molti soldi è: "non si tratta di beni di prima necessità: puoi farne benissimo a meno. In tempi di crisi si deve tirare la cinghia."<br />\n"
"Poi c'è sempre chi si giustifica con l'argomentazione seguente: "Chi scarica illegalmente, non sarebbe comunque disposto a pagare per quei prodotti. Per cui il danno in realtà non esiste. "")
subst = "[quote=\"$1\"]$3[/quote]"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.DOTALL)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.