package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[a-fh-mp-rt-z]|[go]'?|ng?|sh?`)
var str = `o'zbek`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}