$re = '/([a-zA-Z0-9.-]+)[.]/m';
$str = 'D:\\mypath\\Temp\\abs\\device\\Program1.lua
D:\\mypath\\Temp\\abs\\device\\SE1_Test-program.lua
D:\\mypath\\Temp\\abs\\device\\Test_program.lua
D:\\mypath\\Temp\\abs\\device\\Device_Test_Case-general.lua
D:\\mypath\\Temp\\abs\\device\\Char_Satu.lua';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);