import re
regex = re.compile(r"\[!([^]]+)\]", flags=re.MULTILINE)
test_str = ("[!foo]\n"
"[!something]")
subst = "[! \\1 ]"
result = regex.sub(subst, test_str)
if result:
print(result)