package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(.*)\w{2}\.`)
var str = `A.B.CD.1.EF.2.G.3.HI.JKL`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}