$re = '/https?:\/\/shopee\.co\.id\/([\w.\'_-]+(\/([\w-]+))?)/';
$str = 'https://shp.ee/auu7tfs.sa';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);