using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"1(?>[^12]++|(?R))*2";
string input = @"111222222 112222 1111222";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}