$re = '/^\((?:\+55)?\d{2}\)\d{2}-\d{3}-\d{3}$/m';
$str = '(+5511)22-333-444
(11)22-333-444';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);