re = /(?<=: |^(?!.*?: )).*(?=\n\.)/m
str = 'Title1
......
Title2: Description
...................
Title3
......'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end