$re = '/(\$\$(\w+)\(\0\)|[^\$()]{2}\w+)/';
$str = '$$foo(bar, $$goo(car))';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);