const regex = /( `\n)( query \{\n)( .*)(\{\n)( (.|\n|)[^;]*)( \}\n)( \}\n)( `)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('( `\\n)( query \\{\\n)( .*)(\\{\\n)( (.|\\n|)[^;]*)( \\}\\n)( \\}\\n)( `)', 'gm')
const str = `import { gql } from '@apollo/client';
const getAccountingSubject = gql(
\`
query {
accountingSubjects {
id
accountingSubjectNumber
accountingSubjectTypeId
accountingSubjectType {
name
code
}
accountingSubjectPrefixCodeId
accountingSubjectCompanyType
name
note
}
}
\`,
);
const getAccountingSubjectById = (id) =>
gql(
\`
query {
accountingSubjects (where: {id: {eq: \${id}}}) {
id
accountingSubjectNumber
accountingSubjectTypeId
accountingSubjectType {
name
code
}
accountingSubjectPrefixCodeId
accountingSubjectCompanyType
name
note
}
}
\`,
);
export default {
getAccountingSubject,
getAccountingSubjectById,
};
`;
const subst = `$1$2$3{\n totalCount\n pageInfo {\n hasNextPage\n hasPreviousPage\n }\n item $4 $5 }\n$7$8$9`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);