using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:(?!AN-\d+).)+|(AN-\d+)";
string substitution = @"$1";
string input = @"2 BILLING ID AN-19 RPS Ex : “00411850177 “
3 FILLER AN-11 RPS EX: “ “
4 FILLER AN-15 RPS EX: “ “
5 FILLER AN-30 RPS EX: “ “
6 FILLER AN-2 RPS EX: “ “
7 FILLER AN-1 RPS EX: “ “
8 BILLER CODE AN-4 RPS Ex : “1310” 1302 means PDAM Mitracom
9 FILLER AN-11 RPS EX: “ “
10 ADMIN FEE N-12 LPZ Ex : “000000075000” 11 FILLER AN-11 RPS EX: “ “
12 FILLER AN-12 RPS EX: “ “ ";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}