$re = '/(([l,L]ast(est)?)|[R,r]ecent)/m';
$str = 'Last
lastest
Recent
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);