package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\b[A-Za-zА-Яа-яЁё]*[A-Za-zА-Яа-яЁё]+[.][A-Za-zА-Яа-яЁё]{2,}\b`)
var str = `google.com jopa.ru.com nick.name гугл.рус
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}