#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?s)(\d{10}\sDELIVERED)((.(?!\d{10}\sDELIVERED))*)(?<=\$\d\d\d.\d\d)"
Local $sString = "7605625112 DELIVERED N 1 GORDON CONTRACTORS I SIPLAST INC Freight Priority 2000037933 $216.67 1,131 ROOFING MATERIALS" & @CRLF & _
"04/23/2021 02:57 PM K WRISHT N 4 CAPITOL HEIGHTS, MD ARKADELPHIA, AR Prepaid 2000037933 -$124.23 170160-00" & @CRLF & _
"04/27/2021 12:41 PM 2 40 20743-3706 71923 $.00 055 $.00" & @CRLF & _
"2 WBA HOT $62.00 0" & @CRLF & _
"$12.92 $92.44" & @CRLF & _
"$167.36" & @CRLF & _
"7605625123 DELIVERED N 1 SECHRIST HALL CO SIPLAST INC Freight Priority 2000037919 $476.75 871 PAIL,UN1263,PAINT,3," & @CRLF & _
"04/23/2021 02:57 PM S CHAVEZ N 39 HARLINGEN, TX ARKADELPHIA, AR Prepaid 2000037919 -$378.54" & @CRLF & _
"04/27/2021 01:09 PM 2 479 78550 71923 $.00 085 $95.35" & @CRLF & _
"2 HRL HOT $62.00 21" & @CRLF & _
"$13.55 $98.21" & @CRLF & _
"$173.76" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")