$re = '/^([A-Z]{4})\-([A-Z]{3})\-([A-Z]{1,7})\-([A-Z]{4})\-(\d{3})$/m';
$str = 'DGMR-APG-GPOL-PMGX-001';
$subst = "$3";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;