import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!Referer:(https?(:\\/\\/))?(www\\.)?test\\.com).+$";
final String string = "Referer:http://www.test.online/\n"
+ "Referer:https://www.test.online/\n"
+ "Referer:https://www.test.tv/\n"
+ "Referer:https://www.blah.com/\n"
+ "Referer:https://www.test.com/\n"
+ "Referer:http://www.test.com/\n"
+ "Referer:http://test.com/\n"
+ "Referer:https://test.com/";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}