$re = '/http.*?(?=\")/m';
$str = 'import "http://google.com"; import "http://link.com"
import "http://youtube.com"; import "http://link.com"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);