const regex = /(\d) +(?=G)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d) +(?=G)', 'gm')
const str = `XXX YYY AAA 16Gb 16 Gb 16 G 2 G ZZZ`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);