#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)Date: (?<date>\d{1,2}\/\d{1,2}\/\d{4} \d{1,2}:\d{1,2} [AP]M)|(?<sector>NEFS \d+)|^\s+(?!Date|Subject|NEFS|From)-?(?<fishes>\w[\w ]{0,15}(?=:| up|\d))|(?<weight>(\d+[,.])?\d+(?= lbs))|@ \$?(?<price>\d*.?\d*)(?!\s+lbs)"
Local $sString = "1) Subject: FW: NEFS 11 fish for lease" & @CRLF & _
" From: Claire Fitz-Gerald " & @CRLF & _
" Date: 11/15/2013 3:02 PM" & @CRLF & _
"" & @CRLF & _
" NEFS 11 has the following fish for lease:" & @CRLF & _
"" & @CRLF & _
" -GOM Cod up to 5,000 lbs (live wt) @ 1.40 lbs" & @CRLF & _
" -American Plaice 2,000 lbs .60 lbs or best offer" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"2) From: Claire Fitz-Gerald " & @CRLF & _
" Date: 9/5/2014 9:52 AM" & @CRLF & _
" Subject: NEFS 5 Available Fish" & @CRLF & _
"" & @CRLF & _
" All," & @CRLF & _
" NEFS 5 has the following fish available for lease/trade:" & @CRLF & _
"" & @CRLF & _
" GB EAST cod: 954 lbs @ $0.83" & @CRLF & _
" GB EAST cod: 1,046 lbs to trade for 1,830 lbs GB WEST cod" & @CRLF & _
" GB blackback: 30,000 lbs @ $0.07" & @CRLF & _
" GOM blackback: 800 lbs @ $0.03" & @CRLF & _
" white hake: 6,322 lbs @ $0.13" & @CRLF & _
" pollock: 22,000 lbs @ $0.015" & @CRLF & _
" redfish: 14,000 lbs @ $0.015" & @CRLF & _
" GB yt: 1,873 lbs @ $1.13" & @CRLF & _
" GB yt: 5,127 lbs to trade for 10,254 lbs SNE yt"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")