re = /([a-zA-Z0-9\.-]+)(@)([a-zA-Z0-9-]+[\.a-zA-Z0-9-]+)/m
str = '-1a.@-1a.-1a.-1a'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end