$re = '/(?<=\:)([^:]+)/';
$str = 'detail/:codeId:sss';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;