package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?<name>([!@#$?]*)([A-Za-z0-9]+))+([!@#$?]+)=(?<length>\d+)<<.*$`)
var str = `Examples for valid input:
!Ma$$ka!lu!@=9<<ghtucjdhs
!@Eve?#rest!#=7<<vbnfhfg
Examples of invalid input:
anna@fg<<jhsd@bx!=4
#n...s!n-<<tyuhgf4
Nan$ga!Parbat=8<<gh2tn
!@Ma?na?sl!u@=7<<tv58ycb4845
E!ve?rest=.6<<tuvz26
!K@2.,##$=4<<tvnd
!Shiha@pan@gma##9<<tgfgegu67
!###Anna@pur@na##=16<<tv5dekdz8x11ddkc
Ka?!#nch@@en@ju##nga@=3<<thfbghvn
=9Cho?@#Oyu<<thvb7ydht
Nan??ga#Par!ba!t?=16<<twm03q2rx5hpmyr6
Dhau??la#gi@ri?!#=3<<bvnfhrtiuy
Last note
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}