#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?s)(Object(?:(?!Object).)*?ByteCode[ \t]*:[ \t]*\R+)((?:(?:(?!EndByteCode).)*?(?:(?(3)(?!))(\b\w*?z\b)|(?(4)(?!))(?!\3\b)(\b\w*?z\b)|(?(5)(?!))(?!\b(?:\3|\4)\b)(\b\w*?z\b)|(?(6)(?!))(?!\b(?:\3|\4|\5)\b)(\b\w*?z\b)|(?(7)(?!))(?!\b(?:\3|\4|\5|\6)\b)(\b\w*?z\b)|(?(8)(?!))(?!\b(?:\3|\4|\5|\6|\7)\b)(\b\w*?z\b)|(?(9)(?!))(?!\b(?:\3|\4|\5|\6|\7|\8)\b)(\b\w*?z\b))){1,7})"
Local $sString = "BEFORE:" & @CRLF & _
"" & @CRLF & _
" Object" & @CRLF & _
" Type : InfinityProgram" & @CRLF & _
" LastChange : 2/18/2025 5:15:38 PM" & @CRLF & _
" DeviceId : NetWork_MankatoO\OfcDmp\Vav5_26" & @CRLF & _
" Alias : RmTempSignalPRG" & @CRLF & _
" CreateTime : 2/18/2025 5:13:20 PM" & @CRLF & _
" CreatedBy : Root\Acc" & @CRLF & _
" TimeLocked : 2/18/2025 5:15:38 PM" & @CRLF & _
" InstanceId : 7227/33" & @CRLF & _
" ByteCode :" & @CRLF & _
"" & @CRLF & _
"'ROOM TEMPERATURE CONTROL SIGNAL CALCULATIONS ' Dylan Salisbury Paape Energy Services 5/19/23" & @CRLF & _
"" & @CRLF & _
"Numeric sync, lasthour" & @CRLF & _
"Numeric actn ' control loop "action" 1 or 0 (direct or reverse)" & @CRLF & _
"" & @CRLF & _
"Line StartUp" & @CRLF & _
" Goto RmHappy" & @CRLF & _
"" & @CRLF & _
"Line RmHappy" & @CRLF & _
" If ((IntrLkSystemRun = On) & (TempRmAvg > (StptRoom + 1)) & (TS > 2)) then Goto RmWarm" & @CRLF & _
" TempRmCntrlSig = 50" & @CRLF & _
" DamperPositionz = .5" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"Line RmWarm" & @CRLF & _
" If ((IntrLkSystemRun = Off) or (TempRmAvg < StptRoom)) then Goto RmHappy" & @CRLF & _
" TempRmCntrlSigz = PID11Fct(TempRmAvg, StptRoom, PIDTR[1], PIDTR[2], PIDTR[3], 0.5, actn, PIDTR[4], PIDTR[5], 0.5, 1, TempRmCntrlSigz, 0.005, Date)" & @CRLF & _
" TempRmCntrlSig = (TempRmCntrlSigz * 100)" & @CRLF & _
" DamperPositionz = .25" & @CRLF & _
"" & @CRLF & _
" TempRmCntrlSigzAAAz = XXX" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
" EndByteCode" & @CRLF & _
" Status : Active" & @CRLF & _
" EndObject"
Local $sSubst = "$1Numeric $3, $4, $5, $6, $7, $8, $9\r\n\r\n$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)