$re = '/^\d{1,3}(?:,\d{3})*(?:\.\d+)?$/m';
$str = '111,111.00';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);