#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^rgba?\((\d+)\s*,\s*(\d+)\s*,\s*(\d+)\s*(?:,\s*([.\d]+))?\)$"
Local $sString = "rgb(0,0,0)" & @CRLF & _
"rgb(00,00,00)" & @CRLF & _
"rgb(0, 0, 0)" & @CRLF & _
"rgb(00, 00, 00)" & @CRLF & _
"rgba(0,0,0,0.5)" & @CRLF & _
"rgba(255, 255, 255, 1)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")