$re = '/^(a+(?:;a+)*)?$/m';
$str = '
a
aaaaa
a;a
aaa;a
a;aaaaa;aaa
;aa
a;
;
aaa;;a';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);