re = /\n(?!(\d{3}|[a-z])\.? )/m
str = '123. The airplane will not land in time
if weather is not clear due to rain and storm. Are you acceptable to re
turn the flight? (the question is splitted into 2 or 3 lines)
a yes
b no
c. yes but refund money
d. we will risk and land
123. The airplane will not land in time
if weather is not clear due to rain and storm. Are you acceptable to re
turn the flight? (the question is splitted into 2 or 3 lines)
a yes
b no
c. yes but refund money
d. we will risk and land
123. The airplane will not land in time
if weather is not clear due to rain and storm. Are you acceptable to re
turn the flight? (the question is splitted into 2 or 3 lines)
a yes
b no
c. yes but refund money
d. we will risk and land'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result