// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^0*(\S+)").unwrap();
let string = "ABC0123 -> ABC0123
0ABC0123 -> ABC0123
000ABC0123 -> 0ABC0123";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}