re = /^(([0-9]|[1-9][0-9]|1[0-9]{2}|2[0-4][0-9]|25[0-5]|\*).){3}([0-9]|[1-9][0-9]|1[0-9]{2}|2[0-4][0-9]|25[0-5]|\*)((-(([0-9]|[1-9][0-9]|1[0-9]{2}|2[0-4][0-9]|25[0-5]).){3}([0-9]|[1-9][0-9]|1[0-9]{2}|2[0-4][0-9]|25[0-5]))?|(\/([0-9]|[1-2][0-9]|3[0-2]))?)$/m
str = '1.1.1.1
1.1.1.0/24
1.1.1.1-1.1.1.2
1.1.1.*
1.1.*.1
1.1.*
1.*.*.0
1.*.0
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end