re = /(?:^|\s)(-\S+)/
str = 'слово1 слово2 -минус1 слово3.1-слово3.2 -минус фраза -минус2'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end