#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)MUST (?:(?!MAY).)*"
Local $sString = "( class1-OID NAME 'class1' SUP top STRUCTURAL MUST description MAY ( brand $ details $ role ) )" & @CRLF & _
"" & @CRLF & _
"( class2-OID NAME 'class2' SUP top STRUCTURAL MUST groupname MAY description )" & @CRLF & _
"" & @CRLF & _
"( class3-OID NAME 'class3' SUP top STRUCTURAL MUST ( code $ name ) )" & @CRLF & _
"" & @CRLF & _
"( class4-OID NAME 'class4' SUP top STRUCTURAL MUST ( code $ name ) MAY ( group $ description ) )" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")